Preparing Vungle Unity Plugin v.6.5.2.1 for Windows SDK 6.5.2

Supported Versions of Unity

  • Windows 10 UWP and 8.1 supports Unity 5.3.2+, 2017, 2018 and 2019

Build and Project Settings

Open Build Settings (Ctrl + Shift + B), select Universal Windows Platform under Platform. Make sure Build Type is set to XAML Project since Vungle Unity plugin does not support D3D project build type. 

Then open Player Settings, then Publishing Settings and make sure internetClient permission is granted in the Capabilities menu.

image__2_.png

Setting Up Project Configuration

Under the Project tab, you will be able to find two VungleSDKProxy. Confirm that the following parameters under the Inspector tab, in the Select platforms for plugin and Platform settings sections are properly set.

  • Assets/Plugins/VungleSDKProxy.dll
    • General
      • Auto Reference checked
      • Validate References checked
    • Select platforms for plugin
      • Editor checked
    • Platform settings
      • CPU: Select Any CPU
      • OS: Select Any OS
    image__3_.png
  • Assets/Plugins/metro/VungleSDKProxy.winmd
    • Select platforms for plugin
      • WSAPlayer checked
    • Platform settings
      • SDK: Select Any SDK
      • ScriptingBackend: Any Scripting Backend
    image__4_.png
Powered by Creativity Driven by Performance Sign Up Here

Questions?

Need further assistance, feel free to reach out to us, we’re here to help!

Was this article helpful?