Frameworks not found using the Vungle Unity Plugin for iOS

ld: framework not found GoogleMobileAds

If you're running into the above error when building your exported Xcode project for your Unity application, don't worry, we've got a solution!

 

1)  We recommend you upgrade your Unity Plugin to the latest available from the Vungle Dashboard.  We're making improvements all the time and this issue has been resolved in our latest release.

2) If you can't update right now and need a manual work around, the following steps should work as a stop-gap solution:

  • Open the Build Settings for your target Project
  • Go to 'Frameworks Search Paths'
  • Remove the quotes in the "$(inherited)" path that was added by the Vungle Unity plugin

 

Have more questions? Submit a request

Comments