Preparando o Vungle Windows SDK v.2.0 ou posterior para o plugin Unity

Use essas instruções para preparar seu Vungle Windows SDK (versão 2.0 ou superior) antes de integrar o plugin Unity. Após concluir as instruções neste artigo, siga para Introdução ao Vungle (SDK v. 5.1 ou superior) - Unity.

Conteúdo

Versões do Unity suportadas

  • O Windows (Universal 8.1 ou Phone 8.1) suporta Unity 4 e Unity 5.3.2 ou posterior
  • O Windows 10 UWP suporta Unity 5.3.2+

Configuração do Windows SDK e Visual Studio

Você deve ter a configuração necessária do Windows SDK e do Visual Studio para seu ambiente de desenvolvimento:

Requisitos

Após publicar o projeto de Windows no Unity, seu projeto deverá ter a capacidade de internetClient no ambiente do Unity. Abra Configurações do Build (Ctrl + Shift + B), selecione Windows Store em Plataforma e clique em Configurações de reprodutor. Em Configurações de publicação, no menu Recursos, marque a opção InternetClient, assim:

image3.jpg

Definindo a configuração do projeto

Configuração automática usando as ferramentas do Vungle

O SDK Vungle Windows consiste em três arquivos diferentesVungleSDK.winmd, um para cada versão do Windows: Windows 10 UWP, Windows Universal 8.1 e Universal Phone 8.1. Se você usa o Unity 5 for Windows, deverá configurar alguns ou todos os arquivos .winmd, dependendo da plataforma de destino suportada.

Nós preparamos uma ferramenta de um clique para ajudar você nesse procedimento. No menu, abra FerramentasVungle e selecione Preparar Windows 10 Build ou Preparar Windows 8.1 Build.

image1.jpg

Configuração manual

Na guia Projeto, selecione o SDK Vungle adequado. Confirme se os seguintes parâmetros na guia Inspetor, nas seções Selecionar plataformas para plugin e Configurações da plataforma estão definidos corretamente:

  • Para Assets/Plugins/metro/VungleSDKProxy.winmd:
    Plataforma: WSAPlayer
    SDK: qualquer espaço reservado de SDK
    : Assets/Plugins/VungleSDKProxy.dll

  • Para Assets/Plugins/metro/VungleSDK.winmd:
    Plataforma: WSAPlayer
    SDK: SDK81
  • Para Assets/Plugins/metro/UWP/VungleSDK.winmd:
    Plataforma: WSAPlayer
    SDK: UWP

  • Para Assets/Plugins/metro/WindowsPhone81/VungleSDK.winmd:
    Plataforma: WSAPlayer
    SDK: Phone SDK81

image4.png

Importante: se utiliza o Unity versão 5 para compilar o projeto Universal 8.1 ou Phone 8.1, você deve desativar o uso de Assets/Plugins/metro/UWP/VungleSDK.winmd de uma dessas formas:

  • Selecione Assets/Plugins/metro/UWP/VungleSDK.winmd e, na guia Inspetor , na seção Selecionar plataformas para plugin, desmarque a opção WSAPlayer,

  • Ou exclua Assets/Plugins/metro/UWP/VungleSDK.winmd.

Se utiliza o Unity 4, abra Configurações de PlayerConfigurações de Publicação e altere estas opções:

  • Unprocessed Plugins: Size 1
  • Element 0: VungleSDKProxy.dll

image2.png

Tem mais dúvidas? Envie uma solicitação

Comentários