为 Unity 插件准备 Vungle Windows SDK v.2.0+

请在集成 Unity 插件前参照这些说明准备 Vungle Windows SDK(版本 2.0 及更高版本)。了解了本文介绍的说明后,请继续阅读 Vungle(SDK v. 5.1 及更高版本)- Unity 入门

目录

支持的 Unity 版本

  • Windows(Universal 8.1 或 Phone 8.1)支持 Unity 4 和 Unity 5.3.2+
  • Windows 10 UWP 支持 Unity 5.3.2+

Windows SDK 和 Visual Studio 设置

请确保为您的开发环境设置了必要的 Windows SDK 和 Visual Studio:

兼容性要求

在 Unity 中发布 Windows 项目后,请确保您的项目在 Unity 环境中具有 internetClient 功能。打开构建设置 (Ctrl + Shift + B),选择平台下的 Windows 应用商店,单击播放器设置。在发布设置下(发布设置位于功能菜单中),选择 InternetClient 选项,如下所示:

image3.jpg

设置项目配置

使用 Vungle 工具自动配置

Vungle Windows SDK 由三个不同的 VungleSDK.winmd 文件组成,每个文件用于一个 Windows 平台:Windows 10 UWP、Windows Universal 8.1 和 Universal Phone 8.1。如果您为 Windows 使用的是 Unity 5,则必须配置部分或全部 .winmd 文件,具体取决于支持的目标平台。

我们准备了一键式工具来帮助您完成此过程。从菜单导航到工具Vungle,然后选择准备 Windows 10 构建准备 Windows 8.1 构建

image1.jpg

手动配置

项目选项卡下,选择适合的 Vungle SDK。在检查器选项卡下(该选项卡位于为插件选择平台中),确认以下参数以及已适当地设置了平台设置

  • 对于 Assets/Plugins/metro/VungleSDKProxy.winmd
    平台:WSAPlayer
    SDK:任意 SDK
    占位符:Assets/Plugins/VungleSDKProxy.dll

  • 对于 Assets/Plugins/metro/VungleSDK.winmd
    平台:WSAPlayer
    SDK:SDK81
  • 对于 Assets/Plugins/metro/UWP/VungleSDK.winmd
    平台:WSAPlayer
    SDK: UWP

  • 对于 Assets/Plugins/metro/WindowsPhone81/VungleSDK.winmd
    平台:WSAPlayer
    SDK:Phone SDK81

image4.png

重要提示:如果您使用 5 或更高版本的 Unity 构建 Universal 8.1 或 Phone 8.1 项目,您必须以如下两种方式之一禁止使用 Assets/Plugins/metro/UWP/VungleSDK.winmd

  • 选择 Assets/Plugins/metro/UWP/VungleSDK.winmd,在检查器选项卡下(该选项卡位于选择插件平台部分)清除 WSAPlayer 选项,

  • 或删除 Assets/Plugins/metro/UWP/VungleSDK.winmd

如果您使用 Unity 4,导航到播放器设置发布设置,更改以下设置:

  • 未处理插件:Size 1
  • 元素 0: VungleSDKProxy.dll

image2.png

还有其它问题?提交请求

评论