如果你收到Google's LocationClient is deprecated 警告怎么办

如果你在程序中看到以下这个警告:

Warning:com.vungle.publisher.location.GoogleLocationClientDetailedLocationProvider: can't find referenced class com.google.android.gms.location.LocationClient

你可以忽略这个警告,因为这个并不会影响编译你的app或者广告展示。

之所以有这个警告的原因是因为我们有保留Google以及淘汰的Location client的参考,来确保向后兼容性。这个警告可能会出现在所有没有用最新Google Play Services的开发者和设备上(版本 4.0.30 及以上).

你可以选择更新Google Play Services的版本,如果这个影响你们的程序,这些警告会在关闭compiler flag的时候被忽略掉。

因为并不是所有的用户都会更新Google Play Services,我们希望可以通过这样来解决向后兼容性的问题。

还有其它问题?提交请求

评论